$re = '/(?:^|\G)( {4}|\t)/m';
$str = '<?php
class SomeClass
{
var $property = 1;
function double(int $x)
{
$result = $x + $x;
// line already indented with tabs
// line started with tab, but followed with spaces
// line has 4 spaces in the middle
// line endings with 4 spaces
return $result;
}
}';
$subst = "\t";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;