#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m) - *(.*)"
Local $sString = "1 - I went to the cinema 1" & @CRLF & _
" I went to the cinema 1 - movie title 1" & @CRLF & _
" I went to the cinema 1 - movie title 2" & @CRLF & _
" I went to the cinema 1 - movie title 3" & @CRLF & _
" I went to the cinema 1 - movie tile-with minus" & @CRLF & _
"" & @CRLF & _
"2 - I went to the cinema-theatre 2" & @CRLF & _
" I went to the cinema-theatre 2 - show title 1" & @CRLF & _
"3 - I went to the cinema 3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")