import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " - *(.*)";
final String string = "1 - I went to the cinema 1\n"
+ " I went to the cinema 1 - movie title 1\n"
+ " I went to the cinema 1 - movie title 2\n"
+ " I went to the cinema 1 - movie title 3\n"
+ " I went to the cinema 1 - movie tile-with minus\n\n"
+ "2 - I went to the cinema-theatre 2\n"
+ " I went to the cinema-theatre 2 - show title 1\n"
+ "3 - I went to the cinema 3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}