$re = '/ - *(.*)/m';
$str = '1 - I went to the cinema 1
I went to the cinema 1 - movie title 1
I went to the cinema 1 - movie title 2
I went to the cinema 1 - movie title 3
I went to the cinema 1 - movie tile-with minus
2 - I went to the cinema-theatre 2
I went to the cinema-theatre 2 - show title 1
3 - I went to the cinema 3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);