using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" - *(.*)";
string input = @"1 - I went to the cinema 1
I went to the cinema 1 - movie title 1
I went to the cinema 1 - movie title 2
I went to the cinema 1 - movie title 3
I went to the cinema 1 - movie tile-with minus
2 - I went to the cinema-theatre 2
I went to the cinema-theatre 2 - show title 1
3 - I went to the cinema 3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}