const regex = / - *(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' - *(.*)', 'gm')
const str = `1 - I went to the cinema 1
I went to the cinema 1 - movie title 1
I went to the cinema 1 - movie title 2
I went to the cinema 1 - movie title 3
I went to the cinema 1 - movie tile-with minus
2 - I went to the cinema-theatre 2
I went to the cinema-theatre 2 - show title 1
3 - I went to the cinema 3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}