using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[code\]([\s\S]+)\[/code\]|\[title (.+)\]";
string input = @" [chapter Introduction]
[section First program]
Java is pretty cool, **we love it**, let's learn.
Use the ::javacc:: to compile stuff.
[title C# is also cool]
bla bla
[code]
some java code in here
[/code]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}