# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[code\]([\s\S]+)\[/code\]|\[title (.+)\]"
test_str = (" [chapter Introduction]\n\n"
" [section First program]\n\n"
" Java is pretty cool, **we love it**, let's learn.\n\n"
" Use the ::javacc:: to compile stuff.\n\n"
" [title C# is also cool]\n\n"
" bla bla \n\n"
" [code]\n\n"
" some java code in here\n\n"
" [/code]")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.