// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[code\]([\s\S]+)\[/code\]|\[title (.+)\]").unwrap();
let string = " [chapter Introduction]
[section First program]
Java is pretty cool, **we love it**, let's learn.
Use the ::javacc:: to compile stuff.
[title C# is also cool]
bla bla
[code]
some java code in here
[/code]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}