re = /\[code\]([\s\S]+)\[\/code\]|\[title (.+)\]/
str = ' [chapter Introduction]
[section First program]
Java is pretty cool, **we love it**, let\'s learn.
Use the ::javacc:: to compile stuff.
[title C# is also cool]
bla bla
[code]
some java code in here
[/code]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end