$re = '@\[code\]([\s\S]+)\[/code\]|\[title (.+)\]@';
$str = ' [chapter Introduction]
[section First program]
Java is pretty cool, **we love it**, let\'s learn.
Use the ::javacc:: to compile stuff.
[title C# is also cool]
bla bla
[code]
some java code in here
[/code]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);