#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?>->)(?<method>\w+)\s*\(" & @CRLF & _
" (?>" & @CRLF & _
" (?>" & @CRLF & _
" (?>" & @CRLF & _
" (?>" & @CRLF & _
" (?<parameter1>(?>(?>'\d{1,2}:\d{1,2}')|(?>'[*\s]+'))|(?>'?\d+'?))?" & @CRLF & _
" (\s*,\s*(?<parameter2>(?>(?>'\d{1,2}:\d{1,2}')|(?>'[*\s]+'))|(?>'?\d+'?)))?" & @CRLF & _
" (\s*,\s*(?<parameter3>(?>(?>'\d{1,2}:\d{1,2}')|(?>'[*\s]+'))|(?>'?\d+'?)))?" & @CRLF & _
" )" & @CRLF & _
" )" & @CRLF & _
" )?" & @CRLF & _
" )?" & @CRLF & _
"\)"
Local $sString = "->dailyAt('13:00')" & @CRLF & _
"->cron('* * * * *')" & @CRLF & _
"->everyMinute(1)" & @CRLF & _
"->everyTwoMinutes()" & @CRLF & _
"->everyThreeMinutes()" & @CRLF & _
"->everyFourMinutes()" & @CRLF & _
"->everyFiveMinutes()" & @CRLF & _
"->everyTenMinutes()" & @CRLF & _
"->everyFifteenMinutes()" & @CRLF & _
"->everyThirtyMinutes()" & @CRLF & _
"->hourly()" & @CRLF & _
"->hourlyAt(17)" & @CRLF & _
"->everyTwoHours()" & @CRLF & _
"->everyThreeHours()" & @CRLF & _
"->everyFourHours()" & @CRLF & _
"->everySixHours()" & @CRLF & _
"->daily()" & @CRLF & _
"->dailyAt('13:00')" & @CRLF & _
"->twiceDaily(1, 13)" & @CRLF & _
"->weekly()" & @CRLF & _
"->weeklyOn(1, '8:00')" & @CRLF & _
"->monthly()" & @CRLF & _
"->monthlyOn(4, '15:00')" & @CRLF & _
"->twiceMonthly(1, 16, '13:00')" & @CRLF & _
"->twiceMonthly('1', '16', '13:00')" & @CRLF & _
"->lastDayOfMonth('15:00')" & @CRLF & _
"->quarterly()" & @CRLF & _
"->yearly()" & @CRLF & _
"->yearlyOn(6, 1, '17:00')" & @CRLF & _
"->timezone('America/New_York')"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")