using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?>->)(?<method>\w+)\s*\(
(?>
(?>
(?>
(?>
(?<parameter1>(?>(?>'\d{1,2}:\d{1,2}')|(?>'[*\s]+'))|(?>'?\d+'?))?
(\s*,\s*(?<parameter2>(?>(?>'\d{1,2}:\d{1,2}')|(?>'[*\s]+'))|(?>'?\d+'?)))?
(\s*,\s*(?<parameter3>(?>(?>'\d{1,2}:\d{1,2}')|(?>'[*\s]+'))|(?>'?\d+'?)))?
)
)
)?
)?
\)";
string input = @"->dailyAt('13:00')
->cron('* * * * *')
->everyMinute(1)
->everyTwoMinutes()
->everyThreeMinutes()
->everyFourMinutes()
->everyFiveMinutes()
->everyTenMinutes()
->everyFifteenMinutes()
->everyThirtyMinutes()
->hourly()
->hourlyAt(17)
->everyTwoHours()
->everyThreeHours()
->everyFourHours()
->everySixHours()
->daily()
->dailyAt('13:00')
->twiceDaily(1, 13)
->weekly()
->weeklyOn(1, '8:00')
->monthly()
->monthlyOn(4, '15:00')
->twiceMonthly(1, 16, '13:00')
->twiceMonthly('1', '16', '13:00')
->lastDayOfMonth('15:00')
->quarterly()
->yearly()
->yearlyOn(6, 1, '17:00')
->timezone('America/New_York')";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}