use strict;
my $str = '->dailyAt(\'13:00\')
->cron(\'* * * * *\')
->everyMinute(1)
->everyTwoMinutes()
->everyThreeMinutes()
->everyFourMinutes()
->everyFiveMinutes()
->everyTenMinutes()
->everyFifteenMinutes()
->everyThirtyMinutes()
->hourly()
->hourlyAt(17)
->everyTwoHours()
->everyThreeHours()
->everyFourHours()
->everySixHours()
->daily()
->dailyAt(\'13:00\')
->twiceDaily(1, 13)
->weekly()
->weeklyOn(1, \'8:00\')
->monthly()
->monthlyOn(4, \'15:00\')
->twiceMonthly(1, 16, \'13:00\')
->twiceMonthly(\'1\', \'16\', \'13:00\')
->lastDayOfMonth(\'15:00\')
->quarterly()
->yearly()
->yearlyOn(6, 1, \'17:00\')
->timezone(\'America/New_York\')';
my $regex = qr/(?>->)(?<method>\w+)\s*\(
(?>
(?>
(?>
(?>
(?<parameter1>(?>(?>'\d{1,2}:\d{1,2}')|(?>'[*\s]+'))|(?>'?\d+'?))?
(\s*,\s*(?<parameter2>(?>(?>'\d{1,2}:\d{1,2}')|(?>'[*\s]+'))|(?>'?\d+'?)))?
(\s*,\s*(?<parameter3>(?>(?>'\d{1,2}:\d{1,2}')|(?>'[*\s]+'))|(?>'?\d+'?)))?
)
)
)?
)?
\)/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}