# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?>->)(?<method>\w+)\s*\(
(?>
(?>
(?>
(?>
(?<parameter1>(?>(?>'\d{1,2}:\d{1,2}')|(?>'[*\s]+'))|(?>'?\d+'?))?
(\s*,\s*(?<parameter2>(?>(?>'\d{1,2}:\d{1,2}')|(?>'[*\s]+'))|(?>'?\d+'?)))?
(\s*,\s*(?<parameter3>(?>(?>'\d{1,2}:\d{1,2}')|(?>'[*\s]+'))|(?>'?\d+'?)))?
)
)
)?
)?
\)
"""
test_str = ("->dailyAt('13:00')\n"
"->cron('* * * * *')\n"
"->everyMinute(1)\n"
"->everyTwoMinutes()\n"
"->everyThreeMinutes()\n"
"->everyFourMinutes()\n"
"->everyFiveMinutes()\n"
"->everyTenMinutes()\n"
"->everyFifteenMinutes()\n"
"->everyThirtyMinutes()\n"
"->hourly()\n"
"->hourlyAt(17)\n"
"->everyTwoHours()\n"
"->everyThreeHours()\n"
"->everyFourHours()\n"
"->everySixHours()\n"
"->daily()\n"
"->dailyAt('13:00')\n"
"->twiceDaily(1, 13)\n"
"->weekly()\n"
"->weeklyOn(1, '8:00')\n"
"->monthly()\n"
"->monthlyOn(4, '15:00')\n"
"->twiceMonthly(1, 16, '13:00')\n"
"->twiceMonthly('1', '16', '13:00')\n"
"->lastDayOfMonth('15:00')\n"
"->quarterly()\n"
"->yearly()\n"
"->yearlyOn(6, 1, '17:00')\n"
"->timezone('America/New_York')")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.