const regex = /(?>->)(?<method>\w+)\s*\(
(?>
(?>
(?>
(?>
(?<parameter1>(?>(?>'\d{1,2}:\d{1,2}')|(?>'[*\s]+'))|(?>'?\d+'?))?
(\s*,\s*(?<parameter2>(?>(?>'\d{1,2}:\d{1,2}')|(?>'[*\s]+'))|(?>'?\d+'?)))?
(\s*,\s*(?<parameter3>(?>(?>'\d{1,2}:\d{1,2}')|(?>'[*\s]+'))|(?>'?\d+'?)))?
)
)
)?
)?
\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?>->)(?<method>\\w+)\\s*\\(
(?>
(?>
(?>
(?>
(?<parameter1>(?>(?>\'\\d{1,2}:\\d{1,2}\')|(?>\'[*\\s]+\'))|(?>\'?\\d+\'?))?
(\\s*,\\s*(?<parameter2>(?>(?>\'\\d{1,2}:\\d{1,2}\')|(?>\'[*\\s]+\'))|(?>\'?\\d+\'?)))?
(\\s*,\\s*(?<parameter3>(?>(?>\'\\d{1,2}:\\d{1,2}\')|(?>\'[*\\s]+\'))|(?>\'?\\d+\'?)))?
)
)
)?
)?
\\)', 'gm')
const str = `->dailyAt('13:00')
->cron('* * * * *')
->everyMinute(1)
->everyTwoMinutes()
->everyThreeMinutes()
->everyFourMinutes()
->everyFiveMinutes()
->everyTenMinutes()
->everyFifteenMinutes()
->everyThirtyMinutes()
->hourly()
->hourlyAt(17)
->everyTwoHours()
->everyThreeHours()
->everyFourHours()
->everySixHours()
->daily()
->dailyAt('13:00')
->twiceDaily(1, 13)
->weekly()
->weeklyOn(1, '8:00')
->monthly()
->monthlyOn(4, '15:00')
->twiceMonthly(1, 16, '13:00')
->twiceMonthly('1', '16', '13:00')
->lastDayOfMonth('15:00')
->quarterly()
->yearly()
->yearlyOn(6, 1, '17:00')
->timezone('America/New_York')`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}