#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\+?\d\h*\(\d{3}\)\h*[\d-]+"
Local $sString = "+7 (343) 228-02-08 +7 (343) 203-209-3" & @CRLF & _
"8 (800) 555-92-86 8 (499) 322-16-40 8 (812) 426-10-38"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")