import re
regex = re.compile(r"\+?\d\h*\(\d{3}\)\h*[\d-]+", flags=re.MULTILINE)
test_str = ("+7 (343) 228-02-08 +7 (343) 203-209-3\n"
"8 (800) 555-92-86 8 (499) 322-16-40 8 (812) 426-10-38")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")