re = /\+?\d\h*\(\d{3}\)\h*[\d-]+/m
str = '+7 (343) 228-02-08 +7 (343) 203-209-3
8 (800) 555-92-86 8 (499) 322-16-40 8 (812) 426-10-38'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end