using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\+?\d\h*\(\d{3}\)\h*[\d-]+";
string input = @"+7 (343) 228-02-08 +7 (343) 203-209-3
8 (800) 555-92-86 8 (499) 322-16-40 8 (812) 426-10-38";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}