// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\+?\d\h*\(\d{3}\)\h*[\d-]+").unwrap();
let string = "+7 (343) 228-02-08 +7 (343) 203-209-3
8 (800) 555-92-86 8 (499) 322-16-40 8 (812) 426-10-38";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}