$re = '/(
[A-Z][A-Z]\d\d[A-Z]\[
(\*
|
(
(
(\d|\d\d)-(\d|\d\d)
)
|
(\d|\d\d)
)
)
\]
(,|$)
)+/x';
$str = 'RA01D[1-1],RA01D[17-17],RA01D[2-2],RA01D[18-18]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);