#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:([a-z]+)\s)?(?:([a-z]+)\s)(?:([a-z]+)\s)?str$"
Local $sString = "block str" & @CRLF & _
"block right str" & @CRLF & _
"block right left str" & @CRLF & _
"block right left up str" & @CRLF & _
"block right left up down str" & @CRLF & _
"str" & @CRLF & _
"block" & @CRLF & _
"block right" & @CRLF & _
"block right left" & @CRLF & _
"block right left up" & @CRLF & _
"block right left up down"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")