const regex = /^(?:([a-z]+)\s)?(?:([a-z]+)\s)(?:([a-z]+)\s)?str$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:([a-z]+)\\s)?(?:([a-z]+)\\s)(?:([a-z]+)\\s)?str$', 'gm')
const str = `block str
block right str
block right left str
block right left up str
block right left up down str
str
block
block right
block right left
block right left up
block right left up down`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}