re = /^(?:([a-z]+)\s)?(?:([a-z]+)\s)(?:([a-z]+)\s)?str$/m
str = 'block str
block right str
block right left str
block right left up str
block right left up down str
str
block
block right
block right left
block right left up
block right left up down'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end