// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:([a-z]+)\s)?(?:([a-z]+)\s)(?:([a-z]+)\s)?str$").unwrap();
let string = "block str
block right str
block right left str
block right left up str
block right left up down str
str
block
block right
block right left
block right left up
block right left up down";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}