package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:([a-z]+)\s)?(?:([a-z]+)\s)(?:([a-z]+)\s)?str$`)
var str = `block str
block right str
block right left str
block right left up str
block right left up down str
str
block
block right
block right left
block right left up
block right left up down`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}