import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{([^\\}]*?)\\{ord";
final String string = "T000000 <<< rawdata = [\n"
+ " {\n"
+ " \"ordid\": 56325432,\n"
+ "{\n"
+ " \"test2\": 56325432,\n\n"
+ " \"testr34\": 56325432,\n"
+ "}\n"
+ "]\n\n"
+ "String test: \"{ this is a test {ord hgdshfdsgsdfg}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}