import re
regex = re.compile(r"\{([^}]*?)\{ord")
test_str = ("T000000 <<< rawdata = [\n"
" {\n"
" \"ordid\": 56325432,\n"
"{\n"
" \"test2\": 56325432,\n\n"
" \"testr34\": 56325432,\n"
"}\n"
"]\n\n"
"String test: \"{ this is a test {ord hgdshfdsgsdfg}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")