const regex = /\{([^}]*?)\{ord/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{([^}]*?)\\{ord', 'g')
const str = `T000000 <<< rawdata = [
{
"ordid": 56325432,
{
"test2": 56325432,
"testr34": 56325432,
}
]
String test: "{ this is a test {ord hgdshfdsgsdfg}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}