// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\{([^}]*?)\{ord").unwrap();
let string = "T000000 <<< rawdata = [
{
\"ordid\": 56325432,
{
\"test2\": 56325432,
\"testr34\": 56325432,
}
]
String test: \"{ this is a test {ord hgdshfdsgsdfg}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}