$re = '/\{([^}]*?)\{ord/';
$str = 'T000000 <<< rawdata = [
{
"ordid": 56325432,
{
"test2": 56325432,
"testr34": 56325432,
}
]
String test: "{ this is a test {ord hgdshfdsgsdfg}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);