use strict;
my $str = '[!@#$%^&*()_+.\\/\\\\\\\\;\\\' "]';
my $regex = qr/[!@#$%^&*()_+.\/\\;' "]/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";