using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^A-Z]+$";
string input = @"http://www.example.com/thefolder
http://www.example.com/theDirectory
http://www.example.com/theFolder
http://www.example.com/ThefolDeR
http://www.example.com/THEFOLDER";
RegexOptions options = RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}