const regex = /^[^A-Z]+$/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^A-Z]+$', 'm')
const str = `http://www.example.com/thefolder
http://www.example.com/theDirectory
http://www.example.com/theFolder
http://www.example.com/ThefolDeR
http://www.example.com/THEFOLDER`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}