import Foundation
let pattern = #"^[^A-Z]+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://www.example.com/thefolder
http://www.example.com/theDirectory
http://www.example.com/theFolder
http://www.example.com/ThefolDeR
http://www.example.com/THEFOLDER
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}