$re = '/^[^A-Z]+$/m';
$str = 'http://www.example.com/thefolder
http://www.example.com/theDirectory
http://www.example.com/theFolder
http://www.example.com/ThefolDeR
http://www.example.com/THEFOLDER';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);