import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:[0-9]{12}|[0-9]{10}[A-Z])\\b";
final String string = "4024204455A\n"
+ "192345006900\n\n\n"
+ "4024204455A\n"
+ "192345006900\n"
+ "19234500690000000000\n"
+ "192345006900000A\n\n"
+ "This is a test 4024204455A this is a test\n"
+ "4024204455A this is a test\n"
+ "this is a test 4024204455A\n"
+ "This is a test4024204455A this is a test\n"
+ "4024204455Athis is a test\n"
+ "this is a test4024204455A\n"
+ "This is a test,4024204455A this is a test\n"
+ ":4024204455A: this is a test\n"
+ "this is a test##4024204455A";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}