#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([\w]+)\s([\w.]+)\s([\w.]+)\(([\w ,$]*)\)\s{\s*throw\snew\sIllegalStateException\(\"An\serror\soccurred\swhile\sdecompiling\sthis\smethod.\"\);\s*}"
Local $sString = " public TextStyleSettings clone() {" & @CRLF & _
" final TextStyleSettings textStyleSettings = new TextStyleSettings(this.color.getPercentageProviderService());" & @CRLF & _
" this.fillClone(textStyleSettings);" & @CRLF & _
" return textStyleSettings;" & @CRLF & _
" }" & @CRLF & _
" " & @CRLF & _
" protected void fill(final String p0, final int p1, final int p2, final int p3, final Boolean p4, final int p5, final float p6, final BlurMaskFilter$Blur p7, final String p8, final boolean p9, final IPercentageProviderService p10) {" & @CRLF & _
" throw new IllegalStateException("An error occurred while decompiling this method.");" & @CRLF & _
" }" & @CRLF & _
" " & @CRLF & _
" protected void fillClone(final TextStyleSettings textStyleSettings) {" & @CRLF & _
" textStyleSettings.setSize(this.size);" & @CRLF & _
" textStyleSettings.setStyle(this.style);" & @CRLF & _
" textStyleSettings.setCaseStyle(this.caseStyle);" & @CRLF & _
" textStyleSettings.setTemporaryCaseStyleOverride(this.temporaryCaseStyleOverride);" & @CRLF & _
" textStyleSettings.setColor(this.color);" & @CRLF & _
" textStyleSettings.setUseSystemColor(this.useSystemColor);" & @CRLF & _
" textStyleSettings.setBlurRadius(this.blurRadius);" & @CRLF & _
" textStyleSettings.setBlurStyle(this.blurStyle);" & @CRLF & _
" textStyleSettings.setFamily(this.fontFamily);" & @CRLF & _
" textStyleSettings.setFontFile(this.fontFile);" & @CRLF & _
" textStyleSettings.setTemporaryFontFileOverride(this.temporaryFontFileOverride);" & @CRLF & _
" textStyleSettings.setUnderline(this.underline);" & @CRLF & _
" }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")