import Foundation
let pattern = #"([\w]+)\s([\w.]+)\s([\w.]+)\(([\w ,$]*)\)\s{\s*throw\snew\sIllegalStateException\(\"An\serror\soccurred\swhile\sdecompiling\sthis\smethod.\"\);\s*}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
public TextStyleSettings clone() {
final TextStyleSettings textStyleSettings = new TextStyleSettings(this.color.getPercentageProviderService());
this.fillClone(textStyleSettings);
return textStyleSettings;
}
protected void fill(final String p0, final int p1, final int p2, final int p3, final Boolean p4, final int p5, final float p6, final BlurMaskFilter$Blur p7, final String p8, final boolean p9, final IPercentageProviderService p10) {
throw new IllegalStateException("An error occurred while decompiling this method.");
}
protected void fillClone(final TextStyleSettings textStyleSettings) {
textStyleSettings.setSize(this.size);
textStyleSettings.setStyle(this.style);
textStyleSettings.setCaseStyle(this.caseStyle);
textStyleSettings.setTemporaryCaseStyleOverride(this.temporaryCaseStyleOverride);
textStyleSettings.setColor(this.color);
textStyleSettings.setUseSystemColor(this.useSystemColor);
textStyleSettings.setBlurRadius(this.blurRadius);
textStyleSettings.setBlurStyle(this.blurStyle);
textStyleSettings.setFamily(this.fontFamily);
textStyleSettings.setFontFile(this.fontFile);
textStyleSettings.setTemporaryFontFileOverride(this.temporaryFontFileOverride);
textStyleSettings.setUnderline(this.underline);
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)