const regex = /([\w]+)\s([\w.]+)\s([\w.]+)\(([\w ,$]*)\)\s{\s*throw\snew\sIllegalStateException\(\"An\serror\soccurred\swhile\sdecompiling\sthis\smethod.\"\);\s*}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\w]+)\\s([\\w.]+)\\s([\\w.]+)\\(([\\w ,$]*)\\)\\s{\\s*throw\\snew\\sIllegalStateException\\(\\"An\\serror\\soccurred\\swhile\\sdecompiling\\sthis\\smethod.\\"\\);\\s*}', 'g')
const str = ` public TextStyleSettings clone() {
final TextStyleSettings textStyleSettings = new TextStyleSettings(this.color.getPercentageProviderService());
this.fillClone(textStyleSettings);
return textStyleSettings;
}
protected void fill(final String p0, final int p1, final int p2, final int p3, final Boolean p4, final int p5, final float p6, final BlurMaskFilter\$Blur p7, final String p8, final boolean p9, final IPercentageProviderService p10) {
throw new IllegalStateException("An error occurred while decompiling this method.");
}
protected void fillClone(final TextStyleSettings textStyleSettings) {
textStyleSettings.setSize(this.size);
textStyleSettings.setStyle(this.style);
textStyleSettings.setCaseStyle(this.caseStyle);
textStyleSettings.setTemporaryCaseStyleOverride(this.temporaryCaseStyleOverride);
textStyleSettings.setColor(this.color);
textStyleSettings.setUseSystemColor(this.useSystemColor);
textStyleSettings.setBlurRadius(this.blurRadius);
textStyleSettings.setBlurStyle(this.blurStyle);
textStyleSettings.setFamily(this.fontFamily);
textStyleSettings.setFontFile(this.fontFile);
textStyleSettings.setTemporaryFontFileOverride(this.temporaryFontFileOverride);
textStyleSettings.setUnderline(this.underline);
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}