import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\w]+)\\s([\\w.]+)\\s([\\w.]+)\\(([\\w ,$]*)\\)\\s\\{\\s*throw\\snew\\sIllegalStateException\\(\\\"An\\serror\\soccurred\\swhile\\sdecompiling\\sthis\\smethod.\\\"\\);\\s*\\}";
final String string = " public TextStyleSettings clone() {\n"
+ " final TextStyleSettings textStyleSettings = new TextStyleSettings(this.color.getPercentageProviderService());\n"
+ " this.fillClone(textStyleSettings);\n"
+ " return textStyleSettings;\n"
+ " }\n"
+ " \n"
+ " protected void fill(final String p0, final int p1, final int p2, final int p3, final Boolean p4, final int p5, final float p6, final BlurMaskFilter$Blur p7, final String p8, final boolean p9, final IPercentageProviderService p10) {\n"
+ " throw new IllegalStateException(\"An error occurred while decompiling this method.\");\n"
+ " }\n"
+ " \n"
+ " protected void fillClone(final TextStyleSettings textStyleSettings) {\n"
+ " textStyleSettings.setSize(this.size);\n"
+ " textStyleSettings.setStyle(this.style);\n"
+ " textStyleSettings.setCaseStyle(this.caseStyle);\n"
+ " textStyleSettings.setTemporaryCaseStyleOverride(this.temporaryCaseStyleOverride);\n"
+ " textStyleSettings.setColor(this.color);\n"
+ " textStyleSettings.setUseSystemColor(this.useSystemColor);\n"
+ " textStyleSettings.setBlurRadius(this.blurRadius);\n"
+ " textStyleSettings.setBlurStyle(this.blurStyle);\n"
+ " textStyleSettings.setFamily(this.fontFamily);\n"
+ " textStyleSettings.setFontFile(this.fontFile);\n"
+ " textStyleSettings.setTemporaryFontFileOverride(this.temporaryFontFileOverride);\n"
+ " textStyleSettings.setUnderline(this.underline);\n"
+ " }";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}