use strict;
my $str = ' public TextStyleSettings clone() {
final TextStyleSettings textStyleSettings = new TextStyleSettings(this.color.getPercentageProviderService());
this.fillClone(textStyleSettings);
return textStyleSettings;
}
protected void fill(final String p0, final int p1, final int p2, final int p3, final Boolean p4, final int p5, final float p6, final BlurMaskFilter$Blur p7, final String p8, final boolean p9, final IPercentageProviderService p10) {
throw new IllegalStateException("An error occurred while decompiling this method.");
}
protected void fillClone(final TextStyleSettings textStyleSettings) {
textStyleSettings.setSize(this.size);
textStyleSettings.setStyle(this.style);
textStyleSettings.setCaseStyle(this.caseStyle);
textStyleSettings.setTemporaryCaseStyleOverride(this.temporaryCaseStyleOverride);
textStyleSettings.setColor(this.color);
textStyleSettings.setUseSystemColor(this.useSystemColor);
textStyleSettings.setBlurRadius(this.blurRadius);
textStyleSettings.setBlurStyle(this.blurStyle);
textStyleSettings.setFamily(this.fontFamily);
textStyleSettings.setFontFile(this.fontFile);
textStyleSettings.setTemporaryFontFileOverride(this.temporaryFontFileOverride);
textStyleSettings.setUnderline(this.underline);
}';
my $regex = qr/([\w]+)\s([\w.]+)\s([\w.]+)\(([\w ,$]*)\)\s{\s*throw\snew\sIllegalStateException\(\"An\serror\soccurred\swhile\sdecompiling\sthis\smethod.\"\);\s*}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}