#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(.+)\s(\/.*)\?(.+=.+)+\s(.+)\/(\d\.\d)$\n(^(.+):\s(.*)$\n)*"
Local $sString = "GET /index.html?x=1&y=2 HTTP/1.1" & @CRLF & _
"Host: localhost:8080" & @CRLF & _
"Chunked: yes" & @CRLF & _
"" & @CRLF & _
"GET /index.html?x=1&y=2 HTTP/1.0" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")