re = /^(.+)\s(\/.*)\?(.+=.+)+\s(.+)\/(\d\.\d)$\n(^(.+):\s(.*)$\n)*/mi
str = 'GET /index.html?x=1&y=2 HTTP/1.1
Host: localhost:8080
Chunked: yes
GET /index.html?x=1&y=2 HTTP/1.0
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end