using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.+)\s(\/.*)\?(.+=.+)+\s(.+)\/(\d\.\d)$\n(^(.+):\s(.*)$\n)*";
string input = @"GET /index.html?x=1&y=2 HTTP/1.1
Host: localhost:8080
Chunked: yes
GET /index.html?x=1&y=2 HTTP/1.0
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}