import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.+)\\s(\\/.*)\\?(.+=.+)+\\s(.+)\\/(\\d\\.\\d)$\\n(^(.+):\\s(.*)$\\n)*";
final String string = "GET /index.html?x=1&y=2 HTTP/1.1\n"
+ "Host: localhost:8080\n"
+ "Chunked: yes\n\n"
+ "GET /index.html?x=1&y=2 HTTP/1.0\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}