import Foundation
let pattern = #"^(.+)\s(\/.*)\?(.+=.+)+\s(.+)\/(\d\.\d)$\n(^(.+):\s(.*)$\n)*"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
GET /index.html?x=1&y=2 HTTP/1.1
Host: localhost:8080
Chunked: yes
GET /index.html?x=1&y=2 HTTP/1.0
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)