#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)type=dog[\s\S]*?name=(\w+)[\s\S]*?(color=(\w+))?"
Local $sString = "type=dog" & @CRLF & _
"sex=male" & @CRLF & _
"name=wolf" & @CRLF & _
"color=brown" & @CRLF & _
"type=dog" & @CRLF & _
"sex=male" & @CRLF & _
"name=bob" & @CRLF & _
"type=cat" & @CRLF & _
"sex=male" & @CRLF & _
"name=tom" & @CRLF & _
"color=black" & @CRLF & _
"type=dog" & @CRLF & _
"sex=female" & @CRLF & _
"name=simona" & @CRLF & _
"color=white"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")