package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)type=dog[\s\S]*?name=(\w+)[\s\S]*?(color=(\w+))?`)
var str = `type=dog
sex=male
name=wolf
color=brown
type=dog
sex=male
name=bob
type=cat
sex=male
name=tom
color=black
type=dog
sex=female
name=simona
color=white`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}